The information in this article applies to:
DOVICO Timesheet versions 9.0 and above
Symptoms:
New Databases and Archive databases sometimes fail to be created on a remote SQL Server.
Cause:
This problem occurs when you have a remote SQL Server with a local drive that does not exist on the Application server.
(Sample situation)
- Remote SQL 2005 server has a C: and D: drive.
- DOVICO Timesheet and Timesheet Database Manager installed on the Application server with only a C: drive.
- Using Timesheet Database Manager connect to the remote SQL Server that has a C and D drive.
- Select File, New Database.
- Check create database on remote SQL Server.
- Specify SQL Server Data Path: Give it the local path of D: as it would be on the remote SQL Server.
The create and archive will fail at this point because the software attempts to create the database on the Application server's local D: drive which does not exist.
Important:
DOVICO Timesheet must be upgraded to 9.1 in order for the following resolution to work.
Resolution:
- Download the zip file from the following link. http://www.dovicofiles.com/UserFiles/dbmnewarchivefix.zip
- On the Application Server navigate to Start, Settings, Control Panel, Administrative Tools, Services.
- Under Services locate the DOVICO Job Scheduler service, right click on the service and select Stop.
- Take the files from the zip file and overwrite the files in the following directory on the Application server (by default C:\Program Files\DOVICO Software\DOVICO Timesheet).
- Once the files are copied start the DOVICO Job Scheduler service.
- You will now be able to create and archive a database on a remote SQL Server using Timesheet Database Manager.