The information in this article applies to:
- DOVICO Timesheet version 9.x and SQL Express 2005
Symptoms:
The SQL Express 2005 installation fails with the following error:
- “The installation procedure for SQL Express has failed…"
- “For troubleshooting see “<program files>Microsoft SQL Server\90\setup\bootstrap\log\summary.txt”.
When investigating the log you also see the following error: Failed to validate sa password error 2245
Cause:
The cause is that your Local Security Policy or Domain Security Policy requires the sa account to have a stronger password than the default password supplied during the installation. These settings are stored in your Account Policies/Password Policy section.
Resolution:
- Go to Program Files\DOVICO Software\DOVICO Timesheet and execute msdeinst.exe
- Enter a password for the SQL Express installation that meets the complexity requirements your environment requires. If unsure, we recommend something that contains a mix of lower, upper alphabetic characters and numeric characters and is 10 characters or more. (e.g. DoVicoTimesheet2).
- Take careful note of the new password as this cannot be retrieved in any way.